CMP0073ΒΆ

Do not produce legacy _LIB_DEPENDS cache entries.

Ancient CMake versions once used <tgt>_LIB_DEPENDS cache entries to propagate library link dependencies. This has long been done by other means, leaving the export_library_dependencies() command as the only user of these values. That command has long been disallowed by policy CMP0033, but the <tgt>_LIB_DEPENDS cache entries were left for compatibility with possible non-standard uses by projects.

CMake 3.12 and above now prefer to not produce these cache entries at all. This policy provides compatibility with projects that have not been updated to avoid using them.

The OLD behavior for this policy is to set <tgt>_LIB_DEPENDS cache entries. The NEW behavior for this policy is to not set them.

This policy was introduced in CMake version 3.12. Use the cmake_policy() command to set it to OLD or NEW explicitly. Unlike most policies, CMake version 3.18.4 does not warn when this policy is not set and simply uses OLD behavior.

Note

The OLD behavior of a policy is deprecated by definition and may be removed in a future version of CMake.